Blank Window on Launching Eclipse KNIME 2.2.2 for Linux

I recently tried to run Eclipse KNIME 2.2.2 on a mostly stock Ubuntu 10.4 system. I added the line about -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-x.y.z.q . When I tried to launch with the eclipse script, I get the Eclipse Ganymede splash screen and everything looked like it was working.

Then I get a small blank window titled 'Eclipse', but no Eclipse, even waiting several minutes.  I get the same behavior when trying to run KNIME with the default eclipse.ini file.

Any ideas?

This one could be helpful: http://www.knime.org/node/712

It's essential that you have a xulrunner <= 1.9.0. You can try to disable it entirely by providing an invalid path. The node description and the eclipse help will not work though.

This problem will go away once KNIME v2.3 is out (likely based on eclipse 3.6).

@wiswedel, thanks for the info - your advice worked. Disabling xulrunner by using an invalid xulrunner path did the trick. I was running xulrunner 1.9.2.10  - apparently this is incompatible with the knime eclipse distribution. I'll be looking for xulrunner <= 1.9.0 to get all features.