Bug? Column Filter

Hi,

When trying to use the column filter to exclude columns using a flow variable I can’t get it to work. However, it works perfectly okay with enforce inclusion, see below:

Exclusion:


image
(Retains all 5 columns - should only be left with 3)

Inclusion:


image
(Filters to the two columns in the variable)

Is this a bug or a configuration issue?
I’ve attached a demo workflow.Column_Filter_Demo.knwf (14.1 KB)

Thanks,
Kay

1 Like

Hi @REIDK_AIRP , this looks like it’s a bug, or at least inconsistent with the inclusion one.

The only way I can get the exclusion to work properly is if I set it up like this instead:

Then I get the expected 3 columns:
image

Whereas for the inclusion case, it does not matter how you set it up, since it’s controlled by the flow variable.

4 Likes

Hi @REIDK_AIRP ,

indeed, this is an inconsistency: The exclusion works only if the columns are in the red box in the GUI, as per @bruno29a’s suggestion. For the inclusion case this is independent of the GUI setting.

This should not be the case and I opened a ticket for that (internal reference: AP-17471).

Thanks for reporting and providing an example, that’s greatly appreciated!
Best, Lukas

5 Likes

Thank you both - I think for now I will have to use reference column filters for my specific use case due to the names of columns constantly changing (hence the specific set-up I was trying in the GUI) - will be great to see this inconsistency fixed so thank you for raising the ticket.

Thanks,
Kay

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.