Bug in Visibility of Tables in BIRT Reporting

Hi,

If you generate two tables in a BIRT Report, the first table has visibility set such that it is visible in all report types except for XLS files, i.e. by choosing XLS as true, and the others as false.

In the second table, have this visibility set such that it is only visible in XLS files, i.e. by choosing XLS as false, and all others as true.

You will now find that if you launch an XLS report from within the KNIME client, you get as expected, just the one table you expect to see that you set to be visible for XLS. However, if the workflow is uploaded to the KNIME WebServer, and from here you choose an XLS Report you get an Empty Worksheet. Why is this?, surely it should replicate what the client does.

A way around this bug is for some reason setting the table which is visible to XLS only, to also be visible to the HTML report. This now miraculously makes the table appear in the XLS report from the WebServer.

Simon.

Hi Simon, I played with this a bit, and am not sure I am seeing the behavior as you.  I am able to selectively display elements in xls and pdf outputs (*ahem*, I did not know this was possible before your post, so thanks for that...).  I made a small example workflow, can you give it a try and see if it performs as you expect?  It is configured to provide different outputs for XLS and PDF with all other reports being empty.

Cheers,

Aaron

 

 

Hi Aaron,

At the moment, the workflow you sent me is producing reports on the webserver as expected. I have been adding more functionality to it to try and replicate some of the features of the workflow I am experiencing this problem with, but so far I cannot replicate the bug. I will get back to you when I can reproduce it in this test flow.

Simon.