Bug: Join with missing value


as you can see in the example attacched If I Join (full outer join) 2 table on two keys (e.g. Native-Conuntry and Income) with 2 records cointaining missing   (?>50K)  this 2 records are not associated, and are put on separate rows as if they were different. I think this is a bug.

 Also because, if they were different, the Groupby Node should put them on different rows. But it does not happen so (as you can see the attached wokflow). 

Could you confirm me it's a bug?

Thank you!

I have the same problem but isn't a bug. I think that every sql-like software has this behaviour.

You can resolve this problem changing the null value with an empty ("")

Darbon, first of all thank you.

I worked with other softwares that don't have this problem. But anyway, how can I convert the null value into an empty string? I've tried with String Manipulation node (toEmpty($native-country$)) but then I have the same issue with the Join as you can see in the attached workflow.

Thank you very much in advance!

You're almost there, Iiiaaa. :) You just have to set the String Replacer to Replace Column instead of Append Column. (Or join on the newly created column.) But it's even easier with the Missing Value node.


You have to use the missing value node. Attachment below.

Thank you Marlin and fabienc! Sorry, I forgot to Replace the column :)

How can I replace the null value with an empty ("")  using Missing Value node?    If I write ""  in FixValue  I get "" character and not an empty string.

If you let the value empty it works in the missing node.

Thank you fabienc! It works :)