Bug updating shared Components?

We are using shared components extensively to be able to ensure that we use the same updated functionality across several workflows. This has worked fine, but lately we have noticed that the updates are not working as expected.

Opening a large workflow with several copies of the same shared component we get a notification informing us that the components have been updated and asking if we want to update. Answering yes to this updates some of the components but not all. It seems that copies of the shared component that is placed within metanodes or other components seems to not update. We are on version 4.7.

Hi havarde,

Thanks for letting us know! What Link Type are you using within your shared component?


1 Like


Thanks for looking into this. We are using workflow relative links only.

Best regards


I found a forum thread dealing with a similar problem, hope this helps you:



Thanks. Do you have any idea if this will be fixed or should we just rewrite our worksflows? I guess as nothing has happened since 2020 with this it may not be likely it will anytime soon?

I think these are two concerns:

  1. The issue discussed in the other thread from 3 years ago.
  2. The problem that you are now seeing going from 4.6 (or 4.5) → 4.7.

The first one (1) is an old limitation and also working somewhat according to the (poor) design. (We’d like to fix it but it would cause compatibility issues with old workflows. In any case, I think it’s disconnected from (2).)

Number (2) is interesting. In 4.7 we’ve made refactorings regarding component updates and the logic on how components links are resolved. These were refactorings but no known(!) functional change. If you observe that the update is working differently then we must have overlooked something. We just tried to reproduce the behavior but are unable to get to a broken state (which makes it hard to fix it).

Can you help us reproducing the problem? Either by giving a high-level description of the layout or, better, by breaking the attached workflow group. It contains a workflow and (nested) components and when you edit one component the update is working as expected. Can you break it? Nested Component Problem.knar (48.5 KB)

– Bernd


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.