Bug with double click selection

I have an issue on two computers that after a while of using KNIME mouse double-clicking stops working or becomes very slow to respond. This is the case for all nodes where a double click is required to select a variable or column - eg Rule Engine, Column Rename etc.

Mouse works, tried with different mouses. Not a button issue. Sometimes seems to be resolved by closing the Configuration window of the node and re-opening. Sometimes (for example in Rule Engine) highlighting the cursor again helps.

Have you tried to restart KNIME with the -clean option in knime.ini once?

KNIME start with -clean option in knime.ini

1 Like

Hi there @upriidu,

which KNIME version are you using?



can you give us step by step instruction on how to reproduce that problem?

Additionally it would be good to know:

  • KNIME version (as @ipazin already asked)
  • operating system

Sorry for your inconveniences

Using currently the latest 4.0.2 version on both of my personal PCs paired with Win 10 but it has been a persistent issue the with all KNIME versions. I use KNIME at work PC as well and do not encounter the same issue.

Seems to occure more with big flows and when KNIME has been running for a while but the desktop is i7 7700 with 16GB ram, do not think it is a performance issue.
Double click works within Win.

Typical use case.
Connect “Column Rename” node to a data set node - open configure. Double click on the columns on the left panel to select them into right panel for renaming (in node config view) and nothing happens. Might require 5-6 tries to get it selected.

Mouse sensitivity setup issue? Although double click works fine within other applications.

Both of these machines had previous issues with lagged search in Node Repository which seems to have been fixed with latest versions (search used to make KNIME unresponsive for 5-10 sec at times)

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.