Bug with number data types for concatenate and groupby functions

Hi Guys,

I’ve discovered a bug in knime version 4.6.5, not sure if there have been fixes in more recent versions.

This is what I’ve experienced:

I’ve concatenated numbers with differing types (long, int, double), all sharing the same column names. The concatenate node seems to convert the numbers to a common integer type, which is determined by the input of the top table. This is an example:

This looks perfectly fine until there’s an attempt to GroupBy, eliminating duplicate values. In the background, Knime seems to know that the values are different data types, so unique values aren’t returned.

Usually, Knime would reflect the data type as unknown and represent it as a question mark next to the column, letting you know to do some conversion before data-specific computation.

This causes issues when removing duplicates from the dataset later down the line.

Has this been fixed in newer versions of Knime? If not, is this something that can be addressed in new releases?

I’ve attached a dummy workflow showcasing the problem.
Bug in Knime.knwf (20.7 KB)


Have you tried implementing Column Auto Type Cast node after concatenating, or use math formula node to force it to be a certain datatype?

Hi @Albert123 ,

If you need to convert all of it to Integer Number, just set at the math formula to use it and replace the column.


You could do the opposite too, just modify the function to it and replace the column. All ot then will be the same type and the rest of this process will going on fine.


Bug in Knime - solved.knwf (27.6 KB)



1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.