Built-in Chromium crashing

Dear All,

Since updating to KNIME 4.1(.1), I am having issues running JavaScript views.

Here are the symptoms I am observing:

  • When opening a JavaScript view, a window appears and disappears immediately after
  • Changing the JavaScript viewer to external Chrome worked for a while but is currently not anymore (the installated version is Chrome v80, it is managed by our IT organization so I do not have a possibility to change that version)
  • Tried un-installing and doing a clean re-install to no avail
  • When trying to run chromium manually, I get the “Aw, Snap” message and a crash report by windows. Looking at the console output with logging enabled, I get the following message:
    [7336:11332:0219/170343.275:WARNING:gpu_process_host.cc(1220)] The GPU process has crashed 1 time(s)
    I can close the crash window which will reappear, now saying GPU process has crashed x time(s)
    until finally I get:
    [7336:11332:0219/170519.040:ERROR:browser_gpu_channel_host_factory.cc(138)] Failed to launch GPU process.

Any idea what might be going on? I would not rule out that it might be an IT issue on my side, however, these issues started directly with upgrading to KNIME 4.1. Before that (with 4.0.1 I believe) everything was working without any issues.

Thanks and best regards,


Are you on Linux? Others also seem to have the problem (https://github.com/jupyter/notebook/issues/2836) and running export BROWSER=google-chrome seems to solve it for them.
Kind regards

Edit: For Windows, it seems that you have to install a couple of updates.


there is also the possibility to deactivate the gpu support of the browser, if this is what’s causing the problem. You can do so by going to the JavaScript Views preferences page and adding –disable-gpu to the additional command line arguments field.

Best regards,

P.S. All command line switches can be found here: https://peter.sh/experiments/chromium-command-line-switches/


Dear All,

Thank you for all the pointers. Disabling GPU acceleration via toggle did not yield any results, and none of the other suggestions in the first post led anywhere.

I did some further digging, though. Dropping in a different build of Chromium instead of the bundled v78.0.3904.87 turned out to work. I tried both an older (v78.0.3904.0) as well as a newer (v78.0.3904.106) build and both start-up without issues and successfully show Javascript content.

I am not sure what is different about the bundled Chromium vs. the builds that I used but at least I can actually use KNIME again and view JavaScript content now.

Thanks for your your support and best regards,


Hello All,

I do have the same issue.
But i don´t understand what is the right resource to download Chromium and how to replace it
correctly inside the KNIME folder.

Can anybody give me a explanation!

Thanks in advanced,


i solved the issue.

Following this thread:

and the answer of Motsel

  1. Look up the version number (for example “44.0.2403.157”) in the Position Lookup
  2. In this case it returns a base position of “330231”. This is the commit of where the 44 release was branched, back in May 2015.
  3. Open the continuous builds archive
  4. Click through on your platform (Linux/Mac/Win)
  5. Paste “330231” into the filter field at the top and wait for all the results to XHR in.
  6. Eventually I get a perfect hit: https://commondatastorage.googleapis.com/chromium-browser-snapshots/index.html?prefix=Mac/330231/
  • Sometimes you may have to decrement the commit number until you find one.

Copy the folder content to:

by keeping the folders “Visual Elements”, “Extensions” and “WidevineCmd”
made Cromium with these settings below working


1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.