call Local workflow fails in batch mode

hope you are doing well.
I have workflow in which I use the Call Local Workflow(Row based) node to run another workflow and generate an excel file as the report.
when I run the work flow in KNIME AP it works fine but running the workflow in batch mode throws exit code 4.
is it possible to use the Call Local workflow node in the workflows which are executed in batch mode?
Thanks in advance

1 Like

Hi @bahare_njf96,

Regarding the solution by @jan_lender for the same issue, try using a relative path (to workflow):

I still get exit code 4 even by using relative path but I’m on the latest version of KNIME (4.4.1). I hope it would work for you.

In KNIME 4.4.1, I cannot even use writer nodes in batch mode (tried excel and table writer nodes). The output file won’t be written and even more strange, when I don’t use “-nosave” option and I check the workflow after running it in batch mode, the writer node is gone!

Is it something that should be fixed in the next versions?


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.