Call workflow node

#1

Hi,

When I try to use the Call workflow (table based) node on a workflow published on our knime server, I am getting an error 'Attempt to change read-only property ‘outputValues’ – see screenshot attached.

This does not occur when the workflow path points to the workflow located in my local environment.

Any idea what’s going wrong?

Thanks in advance for your help,

Regards,

Claire

0 Likes

#2

Hi @Claire,

can you check the permissions of that workflow on the server and make sure that the user configured in your KNIME Server Connection node has rights to execute the workflow?

Best,
Marten

0 Likes

#3

Hi Marten,
Yes I checked and I have the proper rights.
Actually, I got either this error message or another one “failed to apply settings: Invalid workflow path”. I am unable to configure the call workflow (table based) node. This works perfectly when the workflow is in my workspace.
The workflow I am calling creates an output file and I am using a file download quick form in a wrapped metanode to download it. I did a little bit of investigation and I realized that when I remove this wrapped metanode, I am not getting the problem anymore. Is this a bug? Is there an incompatibility between the Call workflow and the File download quick form?
Thanks,
Best,
Claire

0 Likes

#4

Hi @Claire,

I’ve sent you a PM for follow up.

Best,
Marten

0 Likes