can not read or write files to server


#1

Hi,

if I try to read files from the server or write files to server using the Explorer Browser and Explorer Writer Nodes, then I get following error messages:

There are messages for workflow “02_Write_files_into_the_Server_Repository 2018-07-03 11.14.20”
URL to File Path (Variable) 0:6 - ERROR: Configure failed (IllegalArgumentException): URI is not absolute
CSV Writer 0:20 - ERROR: Configure failed (IllegalArgumentException): URI is not absolute
Explorer Writer 0:19 - ERROR: Execute failed: URI is not absolute

If the workflow runs on my local machine everything works fine, but if I run it on the server I get the errors.
In the nodes i use the knime protocol for the path. I tried knime://knime.mountpoint/test.csv and knime://knime-server-prod/test.csv.


#2

Hi @alsc,

which version of KNIME Analytics Platform are you running locally in conjunction with which KNIME Server version? It’s possible that this error is due an expired licensed (which should not happen with newer KNIME Analytics Platform/Server combinations).

Best,
Stefan


#3

Hi @alsc,

Thank you for pointing out the problem.

The problem why the workflow doesn’t work on a server is the URL to file Path (Variable) node which currently does not work on a server. I’ve updated the workflow so that it also works on a server and it will be soon updated on the Examples server, for now please find attached the updated workflow.

02_Write_files_into_the_Server_Repository_upd.knwf (47.3 KB)

Best,
Anna


#4

Hi @amartin,

I tried tried it already without the URL to file Path Node and I got the same error messages. And even with your updatet workflow i still get the same errors:
1

Best,
Alex


#5

Hi @stelfrich,

I’m using KNIME Analytics Platform Version 3.5.2 on my local machine and the KNIME Server Version is 4.4.0.

Best,
Alex


#6

That’s interesting. We can’t reproduce the error on our 4.4.2 test machine - which doesn’t have to mean anything. It could, however, be that this particular bug has been fixed between 4.4.0 and 4.4.2. Is it possible for you to update the installation to 4.4.2 to see if the issue persists?

Also, which operating system is the server running on?


#7

No it’s not possible for me to update the installation on the server, because it is the server of the university of applied sciences. Maybe my professor can do something to update it. He already contacted you per email.

The operating system of the server is an Ubuntu 16.04.3.

If I’m using the absolute paths on the server like /home/knime/… then everything works as expected. Only if try accessing the files via knime protocol, I get the error messages.


#8

Could you please try to run the following workflow and check if you get the same error message:
TestCSVWriterWithRelativePath.knwf (42.3 KB)

If that’s the case it would be helpful to get the log files of the executor (there are instructions on that in the Server Administration Guide), since I can’t reproduce the issue on my KNIME Server 4.4.0 instance.


#9

This Workflow produces the same Error Message:
2

I have sent you the executer log file via email.


#10

If you find the time, you could give TestCSVWriterToWorkflowDirectory.knwf a shot and send me executor log via email.

In general, I would recommend to update to a more recent KNIME Server and executor and get back to us if the issue persists.