Can’t find Lhasa public plugin in the Business Hub

Hello everyone

When I executed the workflow who has “Remove Empty Rows” node in the Business Hub 1.6.0, the following error message appeared:

※ The workflow can be executed in the KNIME Analytical Platform 4.7

How can I solve the problem?

Thanks in advance

Hello @laughsmile ,

The error message clearly says that the Lhasa public plugin extension is missing.
(The workflow runs locally because I believe the on your local environment this extension has been installed previously.)

But you need to install the extension on your hub executor as well.
Please consult this document about the steps how to add an extension to an existing docker image:



Thanks for your answer.
Create a new file “dockfile”

build a Docker image from the dockfile

retag the image

After the above operations, I executed the workflow again , but can still not find Lhasa public plugin:

What is wrong with it?
Best Regards

I also try to create a new Execution resource with the above docker image:

But it hanged when starting up

Hello @laughsmile ,

My hypothesis is with your final command (instead of adding the extension to an existing docker image)

you created a custom executor docker image and push that image to a docker registry (Embedded Registry)

There is a configuration on the Kots Admin page, where you can enable your own Embedded Registry with the Hub.

Could you please check if it is enabled or not? (It should be enabled and configured if you would like to use your own embedded docker images.) Please see reference documentation here:


1 Like

Hello @dora_gcs

I had enabled Embedded Registry with the Hub from the installation of Business Hub.

After the following operations, the Execution resources works as running status now.
① sudo vi /etc/docker/daemon.json
“insecure-registries” : [“registry.hub.○○○.○○○”]
② Authenticate with the registry

③ Push image to the registry

At last, restart the Execution resources.

Thank you for your follow-up.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.