Can’t update or install any extension

Hello, I am working through a corporate computer that does not have administrator rights, and I need to install a series of extensions, what is done in these cases? any way to install without the rights?

Thank you

Hello @Jalvear ,

Welcome in the Forum.

Only for clarification, what kind of OS do you use? Did you try to update or install extensions and you failed or you has not tried it at all so far?

In the meantime please check this document, especially the CVE-2022-31500 section I hope you will find the solution there.

Kind regards

Hello @dora_gcs thanks for the reply.

In answering your questions, I use a windows operating system and I already tried to download extensions and it was not possible, I attach the images of the error. On the other hand, I read the document and I think there is an error, after asking them to update knime this came up, however I don’t know how to fix it, I would appreciate it if you could give me a guide.

Thanks for the reply
kn1
kn2

Hi @Jalvear ,

so if I am correct the admin on your computer installed all the extensions what you needed?
After the installation you wanted to use a new component (never used before, never downloaded on your local file system)? Correct?

The error msg could be because of proxy settings. Please check this post, in this proxy situation is duly explained:

Good luck!

no, the administrator has not installed extensions, the problem is that the administrator is in charge of the IT area, what I want to do is to know if there is a way to install new extensions without being the administrator

hello follow the steps and install the extension but the node does not appear


kn4

Here is an example like the others if they were installed but this one is not

Hello @Jalvear ,

I am really sorry that you are still struggling with it.

In your first picture (already installed dialog) the “Optimization extension” has a version 4.3.0.

In your second picture (install dialog) it is shown “Optimization extension” is installed with version 4.6.0. (The grey icon shows what is already installed.)

Which is controversial. I would suggest to start from the beginning:

  1. Uninstall your AP
  2. Install the latest version of AP which is 4.6.1 at the moment. (It is possible to install AP and extensions as well without admin rights, using the the self-extracting archive or the ZIP file for more information please see the document linked in my first reply on this thread. )
  3. Install again the extensions what you need. (In the most case “KNIME & Extensions”, “KNIME Community Contributions”, “KNIME Lab Extensions”, would be a good start.)
  4. Restart your AP application.

I hope this will solve this situation!
Please give us a feedback if the re-install did not solve the problem.

Kind regards

2 Likes

Hello @dora_gcs problem solved effectively it was the problem you mention, I had to install the latest version, it does not allow overwriting because the node does not appear in that case, I can now work happily with KNIME, thank you very much for following up on the problem, I am glad to see that it was solved Thanks a lot.

Best regards

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.