Cannot Connect KNIME to Companies House via REST API (get 401 Error)

Hi Everyone

First off - I've gone in the first instance here on the Companies House developer forum. No responses as yet.

As it seems more of a KNIME issue than an API issue I thought I'd try here.

To access the API, you need an 'App' and a token. I have signed up for both of those. I've then tried to perform some simple 'GET' requests using KNIME, e.g. a search for all companies with 'Tesco' somewhere.


The documentation says that it uses BASIC authentication; but your token is your username and there is no password. I've therefore put my generated token in the 'User' field in the KNIME node.

But this returns a '401' error; the console outputs:

ERROR GET Request          4:1        Execute failed: Wrong status: 401 Unauthorized

I'm able to use my token to access data through the API on the built-in test, and through a REST client in firefox - and I've double(triple)-checked my typing of the API token...

So I'm not sure what to do. Some developer threads on the forum suggest that the key may need to be base-64 encoded before sending - e.g.;

As per the second link, I've tried using the online base64 encoder, copying and pasting it in, but no joy... still 401.

Any thoughts/help gratefully received!



Have referenced this thread with the one on the Companies House firum

Hi Neil, I tried this myself and ran into the same issue as you describe. I’ve asked one of my colleagues to look into it in more detail.