Cannot connect to KNIME server

Hello all,

i’m trying to connect to our internal knime server, however i cannot input the credentials etc. as the fields for them simply disappear after a second.

i did this

grafik

when i click on KNIME ServerSpace the following pops up for a second:

then the fields for connection testing and credentials simply disappear and i get a

“Please enter a valid mount ID”.

Entering the mount ID and the server address doesn’t change anything here…

thanks for your help

Andreas

Hello Andreas,

The way that the second screenshot appears suggests some kind of UI/graphics glitch may be going on. Can you please tell me what OS and KNIME AP version you are using in this example?

Regards,
Nickolaus

Hello Nickolaus,

yes is guess that is exactly what’s happening.
OS is Windows 10
KNIME version is 4.2.0

many thanks

kind regards

Hello,

I tested this with AP 4.2.0, 4.2.1, and an instance of 4.2.3 that had been upgraded to 4.2.4.

In each instance, when I add a new configured mount point, and click KNIME Serverspace, I see a brief flash of a window configuration that then leaves Credentials grayed out and mount ID blank, with Server Address: http://localhost:8080.

I started a server instance (4.11.2) and changed “localhost” to the IP address of the server, then clicked down to Mount ID, and it reached out to the server address and autopopulated the Mount ID. I clicked ‘OK’ and it took me back to the list of configured mount points. I clicked ‘apply and close’, and it then showed the new listing in the KNIME Explorer window.

I believe that the initial graphics “glitch” you’re seeing is the window defaulting to localhost:8080 as the server address, attempting to reach out automatically, the window shifts to the correct display boxes for that option, and then it fails to detect a server at localhost:8080 and shifts back, so fast that it looks like a visual glitch. The functionality of adding a server is working as expected.

That being said, I have created defect AP-16119 to track this issue and see what can be done to correct it going forward.

Please let me know if you have any additional questions or concerns.

Regards,
Nickolaus

@NDekay

thanks for the extensive reply and testing it from your end.

is there in the meantime a workaround i could use?
so might be i didn’t get it but can i set the default to something else then localhost?

kind regards

Andreas

Hello,

I don’t think you can set a default other than localhost for the initial creation of the screen, but you can change the server location to whatever address or hostname your actual server has and it should update/create OK once you do that and it finds the mount-point automatically.

That being said, it is a momentarily visual issue only and does not impair you from changing the address to set up a valid server connection. The visual issue will be addressed in future builds.

Thank you,
Nickolaus

Hello @NDekay ,

that is actually what i did so i entered the server address and the mount point but still cannot add the server to the list
grafik

i tried it with network connection settings on manual (with http, https and socks set with port and password so that i can dial out of the intranet), direct and native

still always the same error

thanks

Andreas

Hello Andreas,

I will reach out to you directly via the e-mail address associated with your forum account; I think it would be faster to hold a video call some time to see if we can work through the issues directly instead of through screenshots and descriptions.

Thanks,
Nickolaus

Hello @NDekay
thanks for your effort but the problem got solved.
i had an old cacerts file that didn’t allow the connection.
after is changed it, it now works.

many thanks

Andreas

Hello Andreas,

I’m glad to hear that you were able to figure out the root issue. Good work!

If you have any additional concerns about this issue in the future, please open a new case and we will be happy to assist you further.

Regards,
Nickolaus