Cannot drag and drop new nodes in workbench

Hi,

whenever I try to drag and drop a new node into any workflow I get a ‘URL can’t be dropped in KNIME workbench’ message. Also I cannot connect to the KNIME hub. I believe this is due to network security issues within the company I work for, but is there any workaround? I’d really appreciate if anyone could help.

Thanks!

1 Like

Hi @VV86

If you need to use a proxy to access the internet, you can set that under File → Preferences → General → Network Connections by setting the Active Provider to Manual and configuring the Proxy entries.

If that doesn’t work you can also manually download and point KNIME Analytics Platform to local update sites: KNIME Analytics Platform Installation Guide

Kind regards
Marvin

2 Likes

Hi Marvin,

thanks a lot for the help! Actually I believe it would be easier for my situation to manually download, but I’m truly a beginner and this is going to be naive but, I’m not sure how to download a ‘node’, in the guide it explains how to download multiple extensions but not nodes. I’m sure I’m missing something.

Thanks!
V

Hey V,

no worries, that’s what we’re here for :slight_smile:
When you drag&drop nodes from your browser into the KNIME Analytics Platform, it checks the update sites whether they know an extension that includes the node.
Probably your company’s network setup doesn’t allow that access to the default update sites. Your IT department might be able to send you the information you need to set up a proxy as mentioned before.

If that’s too much trouble or not possible, the guide shows you how to download the content of our update sites (i.e. all extensions) and point KNIME at the archive(s). When you then drag&drop a node into KNIME, it will look in the local archive for a fitting extension and install that out of the archive. Maybe this very professional drawing helps demonstrate :smiley:

Hope this makes sense :slight_smile:

Kind regards
Marvin

2 Likes

Hi Marvin,

Thanks a lot for the explanation and the surprisingly clear professional drawing :smiley: !! I’ve followed your instructions, but I’m still getting this when I try to drag and drop
image

I’m sure I’m missing something obvious but I can’t figure out what it is
Thanks
V

HI V,

I’m afraid you’re not missing anything – I missed this case. The example node you have here is a component.
Components (± nodes mad up of other nodes) have to convey which nodes (and settings) they are made of and this information is not stored in the (local) update sites.
To get components to work, you would have to download a workflow that contains the component and import that workflow into KNIME. This surely is quite tedious.

Maybe it’s worth a shot after all to ask your IT department whether there is a proxy available (you want to access hub.knime.com and update.knime.com)? If they do, you can enter those settings like so:

Kind regards
Marvin

Hi Marvin,

Maybe I get it now but… I’ve found a workflow with the component and I’ve checked I have all the extension installed. Unfortunately now I get this



I assume that is because I can’t access the settings for each node?
I know my IT department will not help, I guess I need to give up :frowning:
V

Hi @VV86

sorry for the late reply! This might not be an issue. Linked components do contain all nodes and settings themselves, they just won’t be able to update, incase someone changed the component to which the link points. To avoid these checks, you should be able to right click the components (with a small green arrow on them) and then unlink them.

Kind regards
Marvin

1 Like

I have the same problem.
This is one of event detail.

Hi @florencio

have you investigated whether you have a proxy available and if not tried the offline update sites as described in the first messages of this thread?

Kind regards
Marvin

Hi V, are you able to connect the internet by your mobile hotspot? I had the same problem (company network connection as well) and I just changed the Network Connection – Active Provider – Native. Then I was able to download what I need thru Help button – Install New SW, then look for what you need in a list. Of course I had to use my own net connection, so I dunno if it will help, but it’s ok for me ;).

BR

2 Likes

For certificate issues (PKIX path building), this may also help:

Kind regards
Marvin

3 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.