Can't access gsheets from a Shared Drive

Hey everyone!
I’m new to KNIME and I’m trying to access a gsheet from a shared drive (not my drive). I was using Google Authentication → Google Sheets Connection → Google Sheets Updater but the file I need is not in the options dropdown.
Already tried adding the file to starred which was one of the solutions in the site, but it didn’t work. Also tried using Google Drive Connector and File Reader but they don’t support google sheets.

Can anyone help?

Hello @solabelleyro and welcome to the KNIME Forum.

Could you send us a screenshot or better yet, the workflow (you can remove the credential) with the problem so we can reproduce it and find a solution as soon as possible?

All the best,

Jose.

Thank you Jose! here is a screenshot (if you can walk me through how to add the whole workflow I’m happy to do that too). But really my question is more about the gsheets node itself. When I go looking for the file I want (which is in a shared drive) I can not find it. Is there a way to access sheets from a shared drive?

knime

Hi @solabelleyro

I reproduced your problem with a GoogleSheet shared from a shared Drive from my colleague and it works perfectly.

  • Could you make sure that the name is correct and shared properly?
  • Could you also restart the workflow from the Google authentication node?

Looking forward to hearing from you.

All the best,

Jose.

Hey Jose! glad to hear it’s possible, I just have to find the right way to set it up. Thanks for sharing!
This is the way I have the filed shared in the shared drive


then when I re-signed in and clicked on select , still not seeing it. Do I have to share it to a KNIME account or something?

Thanks again,
Sol

Hi @solabelleyro

In my case, my colleague shared with me in a shared folder on KNIME.

So in the General access you can see it as “Restricted” but the folder where the Google Sheet is, it is Shared with my user. So probably if you change the rights to “Restricted” as in my case it should work. Of course, you don’t need a KNIME account. It works with any Gmail email account.

Let me know if you can solve the issue.

All the best,

Jose.

hmm, still trying stuff out. Can I ask if you are listed as “Manager” for the folder where the file is? maybe that’s the issue with me. I’m listed as “content manager”

Hi @solabelleyro

I am the owner of the folder or at least editor.

I don’t have the “content manager” option.

Have you found a solution for that? Maybe you can try with another permission.

All the best,

Jose.