can't connect to Knime Hub


I am trying to connect to My-KNIME-Hub but every time I double click there is a time of loading, and this error message appears:

Error occurred while fetching content: {“details”:“Error id 899bd10d-6796-4d0e-94ab-59e07a5707b2-6”,“stack”:“”}
Error occurred while fetching content: {“details”:“Error id 899bd10d-6796-4d0e-94ab-59e07a5707b2-6”,“stack”:“”}

Please advice,

Thank you

Hi @Carloscowa and welcome to the forum. A few questions for you:

  • Were you able to connect to My-KNIME-Hub before successfully, or is this the first time you’ve tried?
  • Are you connecting over a company VPN? If so, can you try disabling it to see if that has an effect?
  • What version of KNIME and operating system do you use?

Dear Scott,

When I started using KNIME (couple of days ago) I was able to connect to My-KNIME-Hub through the KNIME Explorer at the top left corner on the software.
From today, I can’t connected anymore.

I am not connected over a company VPN, nor on my personal system. I was using Brave browser when I started and when the issue happened.
I now use Google Chrome browser and set it as main browser on my MacBook.
I am using the latest version of KNIME 4.7.1.

FYI: I am able to get to the KNIME Hub through any browser though.

Hi @Carloscowa,

I looked into your issue, and it looks like one of your workflow groups had an invalid name. I renamed the affected workflow group and that should have solved the issue.

Please let me know if you can now access the Hub, or if you are still having issues.

Best wishes,

1 Like

Dear Alison,

This actually solved the issue. I can now log in from the KNIME Explorer area on the software.

I do not really understand how this could happen & I would like to know how did that happened in order not to repeat the same mistake. The software is new to me, so I am a bit goofy.

Many thanks

Hi Carlos,

This issue was caused by a bug in our code, not a mistake on your end :slightly_smiling_face:

From what I can see it looks like items were being moved into a workflow group, and before that process finished a delete request was sent for the same workflow group. The workflow group deletion finished before the move operation completed. This resulted in an unexpected state, which prevented your “My-KNIME-Hub” repository from loading properly.

I’ve created a bug ticket, so we can prevent this issue from occurring in the future. Thanks for reporting this issue, and I’m sorry for any inconvenience it caused you.

Best wishes,

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.