Can't continue loop as the workflow was restored with the loop being partially executed

I created a workflow containing nested loop. It works fine in knime analytics platform. Whereas when I run this workflow in knime server, it is showing workflow did not fully execute. On saving as workflow, an error is showing-> “Can’t continue loop as the workflow was restored with the loop being partially executed”.
The resources available are way higher in server than my desktop and even with small data to process it is giving same error. What is the problem here and how to fix it?

Hi @harsh,
did you check the option to reset the workflow before execution?

1 Like

@Marten_Pfannenschmidt, It works after resetting in desktop. But I cannot do that on server.

There is different ways how to reset workflows on KNIME Server:

  • You could choose to reset before deploying to KNIME Server via deployment wizard
  • You can choose to reset before execution via execution dialog
  • You can open existing workflow on KNIME Server, reset all nodes and save

Have you tried any of these to see whether it resolves the problem?

1 Like

Yes, I reset everything before deploying. It is a fresh start on server. The structure is something like=> read data–
if ():
loop - do something–
else: do something
aggregate records–
save data
It is giving failing inside second loop at very start in server. But whole thing is running in desktop version.
Is this some version issue. Desktop version:4.1.1, Server: 4.11.2

I’ll contact you via private message for further analysis. Will post solution here once it is resolved.

Have the solution? I’m having the same problem

Hi @Gustavo_Bruno and welcome to the community!

Could you please elaborate on your situation? Do you want to execute a workflow on the KNIME Server/Executor and you get the error “Can’t continue loop…” error? This is most likely the case because the workflow is partially executed - you can try resetting it before/while deploying ins that case.

If this is on your local KNIME Analytics Platform a reset of the Loop start node should do the trick.

Kind Regards, Lukas