Can't Create Tensorflow DL Environment

I’ve tried the “create new environment” function in Python Deep Learning preferences and get the follwing error:

I’ve also tried the Conda Propogation configured by @MLauber and it also throws errors:

Tensorflow Propogation

Any help would be much appreciated.

@rfeigel setting up deep learning environments with KNIME is not that easy sometimes. You might want to follow this approach and try it via miniforge.

From the error messages there might be a problem with numpy. In the article a forced re-install off that essential package helped.

Hi @rfeigel,
What OS are you using? The conda environments are OS dependent therefore, it helps to know the OS for reproducing the issue.

Do you have the conda configuration channel_priority set to strict (link to documentation)? The environment defined on the preference page is not resolvable with a strict channel priority. It should be set to flexible.

Windows 11. The default configuration is flexible. I haven’t changed it.

@mlauber71 I created an environment based on the yml in your Medium article. After several reinstalls of numpy and pandas I’m still getting the following error:

@rfeigel you could try to make sure your numpy is smaller than version 1.24. What operating system (Windows, MacOSX/Intel, Apple Silicon) and version of KNIME are you using? I am working on a setting for Apple Silicon at the moment.

1 Like

@mlauber71 Dropping numpy to 1.23.5 seems to have done the trick. I’m running Windows 11. Thanks very much. I’m in awe of what you know about this stuff. You deserve a Knime Hero’s medal for both your knowledge and willingness to help folks like me.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.