Can't install Knime Extension on Linux

I am trying to install the Knime Base Chemistry Types and Nodes extension, and keep getting the error:

Profile id SELF is not registered.

The system is a standard CentOS 7 OS with the GNOME graphical interface. I followed the install procedure for Knime version 4.5.0. I am following the instructions from this link:

The end goal is to get the Molsoft extension installed, but I can’t get past the first part of installing the Chemistry types and nodes extension.

Any help would be greatly appreciated.

Tim Gendorf
Systems Administrator - Linux
Computing and Technology Group (CATG)
Huntsman Cancer Institute

Hi Tim,

I was able to install the Knime Base Chemistry Types and Nodes extension without any issue. Can you please verify that, you have the correct update sites (as in the screenshot below) configured? look out for the version numbers (4.5).

Also, could you please try removing the additional update site provided by molsoft?

If all of this doesn’t help, can you attach the knime.log after the failed installation?
You can find it under the View menu (last item)


1 Like


Thank you for you response.

I have verified the update sites and removed the molsoft site as requested. I attempted another install, which failed with the same error. When I clicked on the View menu last item to look at the log file, it comes up blank with nothing in it. I attempted the install a few more times to see if it would change, but nothing ever shows up in the log file.

Thank you,
Tim Gendorf

Hi @tgendorf , you usually get this error when running an hosted instance of eclipse.

Use the " Support software installation in the launched application" in the launch configuration:

1 Like


Thank you for the response. I have checked the system, and the Eclipse IDE is not installed on the server. We are not running a hosted instance of eclipse. The link you sent was not helpful, since the eclipse software is not installed. I have not seen any instructions that stated eclipse had to be installed to run the Knime software. Is this something we need to install?

Hi @tgendorf , no you do not need Eclipse to run Knime.

I’m not sure what else could be causing this issue. That’s the only thing I can think of

After deleting and reinstalling the application 5 times, I was able to get extensions to install. I don’t know why it decided to start working after that many tries, but it is running.

It’s a weird one @tgendorf . I’m glad that it finally worked for you, and thank you for sharing what you did. Some would have given up after 3 attempts :smiley:

I’m glad that you persevered and it paid off.