Can't key in Chinese word in Table creator or python script nodes or node configuration

I found it can’t key in Chinese word in Table creator or python script nodes or node configuration.
KNIME AP:5.1.1
MacOS: 13.3.1

The correct displaying when key in chinese words as below:

I had tried on other macbooks, also had the same issue. Please help fix this bug.
Thank you very much.

Anyone can help to check it?

Hi @eddy0620 ,
thank you for posting.
It may depend on various things, for instance, knime.ini settings, or the customer localization.

Couple of questions:

  1. Have you used earlier versions of KNIME before and if yes, did you experience the same?
  2. I assume it is possible to view and type the same characters in other programs?

I have tried to find similar cases in the past but there is nothing yet for MAC. We can’t promise a resolution right away, but you could try this procedure, which was advised to a Windows user in the past:
If you switch to classic user interface (:information_source: symbol in the right upper corner → scroll down), than please click File > Preferences > General > Workspace: Set “Text file encoding” is indeed set to UTF-8.


1 Like

In the old version, also had the same issue.
Other programs do not had this issue.
I already set as utf-8 yet.

I asked other Mac users, also can’t key in Chinese words directly. Could you help record it and fix this bug in future.

1 Like

Hi @eddy0620 ,
thank you for all provided information!
I have added plus 1 on your behalf on this matter to the ticket in our internal system (AP-17431).