can't type quotes " and ' in nodes

Since the last update from Knime to 4.4.0 on my MacBook Pro I can’t type quotes such as " and ’ in a node.
In the Workflow annotation and in the search field in Node Repository it works fine. Only in an node
I now use copy paged to get quotes in a node .
Can anybody help me with this?
regards
Peter

Hi @PetervdW

Which version of MacOS are you on? Is it for all nodes, or only for some nodes?

Regards,
Wali Khan

Hi Wall Khan,

I have Mac OS Big Sur version 11.5.1 and it is for all nodes
regards
Peter

Hi @PetervdW,

sorry for the inconvenience, we’re looking into it.

So far, I could not reproduce the problem yet (tried node dialogs, table creator, snippet node, node annotations). Since there have been changes from 4.3 to 4.4 related to locales, I also tried to reproduce in different setups (en_UK, de_UK, de_DE). I’m also on Mac OS Big Sur 11.5.1.

I assume when trying to type a quote (e.g., hitting shift+2 on german keyboard layouts) nothing happens at all?

I’m not on a German keyboard. I’m using the keyboard VS-international so I use the separate key with quotation mark followed by space bar.
i notice that when i switch from keyboard: vs international-pc to keyboard Netherlands, it goes well.

Thanks @PetervdW for the hint on mac international keyboard layout. We’re looking into this.

1 Like

This is probably related to an update of a third-party software component. We asked for support, but if we get none, we might not have the resources to fix this.

We investigated further and indeed this is caused by a third-party library. We filed a bug report at their side and hope for a quick response.

2 Likes

Any fix for this? I’m also experiencing this on MacOS Monterrey v. 12.5.1 with KNIME 4.6.1.
Using US-international keyboard.