CDK Opsin Node in KNIME not working properly?

@egonw - I’m having difficulty with the Opsin node in the KNIME-CDK extension. I’m using very simple names. For the CDK column, I am getting “Object missing (‘?’)” and for the InChI, I am getting
"!DOCTYPE HTML PUBLIC “-//IETF//DTD HTML 2.0//EN”, nothing returned for Png or SMILES. Am I missing something that I might need behind the scenes in order to make this work correctly?


1 Like

Can confirm not working here either.

(the other)

1 Like

@sauberns Thank you for confirming the issue.

@knime - can someone take a look at this? Thanks :slight_smile:

Hi folks and sorry for the delayed response. Let me check to see who would be the best person to assist here.

Hi Scott,

No worries! Thank you for your response! :slight_smile:


Hi Angie @chemgirl36

I’m sorry you encountered problems! We are currently looking into getting in touch with the dev.
As a workaround I can point you to THIS RDKit node, that is using the same library in the back.

Would that work for you?

1 Like

Hi Alice,

Thank you. I did find and use the RDkit node as a workaround. It worked great. I just wanted someone to know that this node wasn’t working properly. I appreciate you reaching out! :slight_smile:

Thank you so much,

1 Like

That doesn’t sound right. HTML feedback suggests to me the use of a webservice. I am not aware something changed on the OPSIN side, but sadly do not have time to explore the problem, nor find/create a direct solution.

I just checked, but seems to work fine.

@chemgirl36, I was looking at the code and tried the OPSIN webservice and cannot see what changed. What KNIME-CDK version are you using? Just trying to figure out what goes wrong…

Actually, what are the SMILES that you are trying to process?

@egonw - I thought the input for OPSIN would be names, correct? to covert to SMILES or InChI.

I was using simple names such as benzene or 2,4,6-trinitrotoluene.

The version of KNIME-CDK I am using is 1.5.600.v202211291308. I believe that was the last time I was prompted for update.

Please let me know if I am using this node incorrectly or if I need to do something special to call the service?


yes, sorry, I meant indeed IUPAC names. Okay, thanks for the examples. That rules out one of the possible causes we were thinking about.

hi all, it looks like we found the issue. The code was calling the OPSIN webservice with HTTP instead of HTTPS, which would explain the found behavior. I just pushed the fix (Use httpS · cdk/nodes4knime@b96692a · GitHub) but I am going to need the help from the KNIME team to make a bug fix release, I’m afraid.


Dear @chemgirl36 and @sauberns,

@egonw s fix has been deployed. Could you please update your CDK Extension (you might need to reload the KNIME Community Extensions (Trusted) Update site, see screenshot to find the Reload button) and tell us whether the issue is gone?

Thanks to you all for reporting and maintaining!

Best regards


Working now here.

Thanks Egon!


@steffen_KNIME , @egonw - Thanks so much for the quick fix! Very much appreciated! :slight_smile: This is why I love you guys! :slight_smile:

@sauberns - Thank you also for confirming the problem and confirming the fix. I have also updated and confirmed the fix :slight_smile:



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.