Cellpose in Knime

Dear Knime community and @imagejan in particular,

I have a Knime workflow which includes the Cellpose node. The node itself is working in its current form, however, I get a warning during the update node check:

WARN CheckUpdateMetaNodeLinkAction Unable to check for update on node “Cellpose Segmentation (CPU) 0:4”: Cannot resolve to local file: resource ‘/Users/imagejan/fmi-basel/components/Cellpose Segmentation (CPU)’ does not exist

Is this a conscious choice to not update the node anymore?



1 Like

Hi @CCI_Liverpool,

Do you mean this component? Cell Segmentation with Cellpose – KNIME Hub
How did you import it into your workflow? Did you drag it in from the hub or did you copy it from the example workflow by @imagejan ? In the later case the error message is most likely caused by the configuration of that workflow, as it refers to a file on Jan’s computer, instead of the publicly accessible hub.


1 Like

Hi Gabriel,

I do not remember how I imported the node into the workflow. However, I replaced the previously used node dragged with the node dragged from the hub and now I don’t get the error message anymore.

It is strange that it worked for months without issue though. Anyway. Thank you for pointing me in the right direction to solve the problem :grinning_face_with_smiling_eyes:

Best wishes,

1 Like

Hi Marie, and sorry for the delay in following up,

Sorry for the trouble. This was likely caused by the renaming of the component node, after some forth and back with @paolotamag in preparation of his recent blog post:

That path is a fake path, as it never existed on my computer, even before the renaming. I guess it is related to how the KNIME Hub works, but I have no insights into technical details here.

@KNIME team: it would be great if renaming a node on the hub wouldn’t break existing update links in this way, or at least generate a more informative error message :wink: anyhow, thanks for the KNIME Hub, it’s a great platform for sharing components!


Hi @imagejan and @CCI_Liverpool
Sorry for the issue.
Yes I just confirmed with our dev team that renaming a component on the hub mount-point from KNIME AP does not break the workflow link (Cell Segmentation with Cellpose – KNIME Hub), but it does however break the link between any workflow adopting an instance of the component and the component master version. This is because KNIME AP uses full paths to check for updates and the full paths carries the name of the component. We are going to fix this soon and sorry for the trouble.

To understand in general how shared components work to stay up to date read here:

Please consider though that when using a component from KNIME Hub the link can be only of type absolute.

@CCI_Liverpool to fix your problem is quite simple:

  • Delete the component in your workflow with the broken link showing the old component name “Cellpose Segmentation (CPU)”

  • Visit the KNIME Hub page with the new component name “Cell Segmentation with Cellpose” at Cell Segmentation with Cellpose – KNIME Hub

  • [This step you have already given that old component version had a conda node inside, adding it here for others who find the thread] Make sure anaconda or miniconda is installed and correctly configure in your KNIME Preferences (Python section). If you don’t already have all of that, install miniconda (much lighter) and simply provide the path of the installation folders in the KNIME Python Preferences. No need to create default conda environment, the conda node inside the component will take care of that.

  • Drag and drop the component from the KNIME Hub page to your workflow and connect + configure like you previously did with the old one, then execute.

After this every time you use the component you should be able to get the latest updates.


  • @imagejan updates the components with a new feature or a bug fix

  • You update the component and you get it in your workflow right away

Sorry for the trouble and I hope this was useful to understand the KNIME feature

1 Like

Hi @imagejan and @paolotamag,

I have fixed the workflow by getting the node from the hub the other day. I also had to add a RowID node though because the RowIDs are now named different compared to the old node, and it broke the workflow initially. The workflow is now fixed and rolled out to facility users :smiley:

Thank you so much for looking into this and providing the background reading on shared nodes.



Great to hear it works now.
Sorry about the IDs. They changed because we added the new joiner node as the previous component version was using a deprecated Joiner node.
Thanks for letting us know.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.