Cellpose python script failed: Serialization error

Hello,

I’m a new user of KNIME and am trying to do some nucleus segmentation using the Cellpose nodes available on the KNIME Hub. I was trying to use the Cellpose Segmentation (CPU) node that I saw on a KNIME tutorial. At some point the node worked; however, when I reset the Image Reader node and reran the nodes, Cellpose node no longer works. It has a error message at the Python Script node: An error occurred during serialization. See log for errors.

workflow.docx (1.5 MB)

When I tried the Cellpose node (not the CPU version), it has the same error message. Though previously when I tried this node, it had a different error message related to absent modules.

I don’t understand why a node would stop working. Any help would be greatly appreciated. Also, where can I find the log for errors?

Thanks
Christine

Hi @yoyo1130,

The screenshot in a word document is not so useful. Can you please can you share the knime.log file?

You can get it from the menu item View → Open KNIME log. Once it is open you can edit and save the text file and attach it here.

Best,
Temesgen

1 Like

Hi Temesgen,

Thanks for your reply. I attached the log. knime_log.txt (4.1 KB)

Thanks
Christine