CellProfiler Nightly Permission denied error=13

I am trying to run the sample workflow CellProfiler_Human on a MAC and ran into the following error:

ERROR CellProfiler Pipeline Executor 2:4        Execute failed: Cannot run program "/Applications/CellProfiler-nightly.app/": error=13, Permission denied

Every setp of the instruction how to execute the workflow was followed.   There was a previous thread (~2 years ago about the same issue) but offered no final solution.  Does anyone knows how to use CellProfiler with KNIME in a MAC OS?  Any help will be highly appreciated.


Hi wmyu,

Maybe you have to run KNIME with admin rights in order to execute CellProfiler from within KNIME?




I’m having the same issue with KNIME (3.7.0) calling Cell Profiler in MacOS

ERROR CellProfiler Pipeline Executor 2:4 Execute failed: Cannot run program “/Applications/CellProfiler-3.1.8.app/”: error=13, Permission denied

The result is the same when launching KNIME with admin rights using the sudo command.

Does anyone have a solution to this? Anyone using Cell Profiler integration in MacOS?


Hi @Keisuke,

Could you please follow the instructions to add the KNIME Image Processing nightly updatesite. Once you have done that you should be able install a more recent version of the CellProfiler integration with a bugfix for what you are experiencing (at least the same error message has motivated my bugfix).

Let me know if you need additional pointers and/or if it works!



Thanks, Stefan! This solved the issue, and I could run this example workflow.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.