Change decimal delimiter in report designer

Dear Knime Users,

can anyone advise me how to change the decimal delimiter in KNIME reports from "," to "."? My windows settings are using points as decimal delimeters, also in the KNIME nodes the point is the decimal delimiter. However, when I create a report with report designer and pdf-Format and if the report contains a table with decimal value, the comma is always the decimal separator. I was searching the preferences and also the forum without success....but probably there is an easy way to solve this simple issues.

Thanks in advance for your support.


1 Like

Dear Stef,

please see the screenshot attached to my post. There you will see one possible solution.


Dear Marc,

thanks a lot. This works indeed, but you would have edit this whenever you create a new report or you update the report. I found out how to change the global settings. Go to "Preferences" -> "Report Design" -> "Preview". For "Choose you locale" select an appropriate language such as e.g. (English, United Kingdom).


Good to know, thanks for sharing!