change memory on knime.ini

Hi,
i got the error: Java Heap Space and I should change the memory of knime.ini

I locate the file but I cannot understand how change the memory, also after read this: FAQ | KNIME

Can you help me?
In other words I didn’t see where type -Xmx4g instead -Xmx1024m as suggested.

Immagine 2022-05-25 102055

Hi @gcas and welcome to the KNIME community forum

In your case, you would need to change -Xmx8085m to -Xmx4g

Hope it helps.

Best
Ael

4 Likes

@aworker to double check:

I believe @gcas is looking to increase it due to being out of memory so going from 8085m to 4g is actually a 50% decrease (4g is an example in the FAQ coming from 1024m). I’d say he’s looking for something like 12g or more depending on installed memory.

4 Likes

Good point @ArjenEX

My apologies, I didn’t pay attention to the amount but just to the fact that @gcas couldn’t find the parameter in the knime.ini file.

In all cases, the syntax for this parameter is either to specify the amount of memory in Megabytes or in Gigabytes. In the case of @gcas, if you need to set it up to 12 gigabytes, it should be as follows:

 -Xmx12g

or alternatively

 -Xmx12288m

given that 1 gigabyte is the equivalent of 1024 Megabytes.

Best
Ael

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.