change socket timeout when running .knwf from knime.ini

Hi

Recently, I have inherited a collection of .knwf files. Most of them make GET and POST calls and the socket timeout is set to a default of 2 seconds. I was wondering if there is a way to change the timeout using knime.ini or similar to increase the timeout in all .knwf files when executed? I would like to avoid changing the timeout in all .knwf files individually.

Hi,
the default timeout for URLConnections can be changed in the VM Arguments:

-Dsun.net.client.defaultReadTimeout=30000
-Dsun.net.client.defaultConnectTimeout=5000

Those can be added in the Knime.ini in the KNIME installation folder. However, I think the settings in the nodes take precedence over those values so it will probably not help.
Kind regards
Alexander

Thank you for the reply, Alexander. Yes, you are right in this case the VM arguments did not change node settings, unfortunately.