ChEMBLdb Connector - Connexion FAILED

Hello everybody,

Everytime I try to extract ChEMBL data with "ChEMBLdb Connector", I get an error message saying :

WARN  ChEMBLdb Connector   0:11       The XML URL may be invalid: Connection timed out
ERROR ChEMBLdb Connector   0:11       Execute failed: Cannot get table: container is not closed.
WARN  ChEMBLdb Connector Input 0:12       The XML URL may be invalid: Connection timed out
WARN  ChEMBLdb Connector Input 0:12       Node created an empty data table.

I have correctly set up my "Network Connections". I don't understand why am I getting this error message ? Can you help me ?

Best Regards,

Baptiste CANAULT


Hi there, 

The nodes are working fine for me. What ChEMBL ID are you using? Are you connected to the internet? Are you behind a proxy?




Hi George,

Thanks for your answer. I use the node example "CHEMBL25" (Active ID on ChEMBL web service) . I am connected to internet and I set up correctly my proxy connexion because the nodes "ChEBI" work fine.

I don't see what the problem is with "ChEMBL" nodes.







Hi Baptiste

Please could you export your workflow as the XML and attach it to a message so that I can see how you're using it?

Alternatively, if you could attach some screen shots of the node settings if you don't want to send the whole workflow. We can then see what could be happening.

I've also tried this from outside of the EBI network and it works fine for me....




...and finally, what version of KNIME are you using? 



Also, just to check, in the search type drop down menu, it should say 'compound' (for CHEMBL25):



Hi George and Lousia,


System : Linux CentOS6.6


KNIME : v2.11.2

EMBL-EBI Nodes for KNIME : v1.0.3.20146271219

Source for EMBL-EBI Nodes for KNIME v1.0.3.201406271219


KNIME v3.0.0 :

EMBL-EBI Nodes for KNIME    1.0.400.201510090835

Source for EMBL-EBI Nodes for KNIME    1.0.400.201510090835


I use exactly the same settings as your example (ChEMBL id = CHEMBL25 - compound)

Please find enclose my WF.

Thanks a lot,





Hi Baptiste

I am working on 2.11.3. I imported your workflow exactly how it was and ran the node. It worked without an issue.

I believe this may be something to with your machine, though I  am not sure what.

Could you try to access the URL:

This is web service that the node is calling so if you can't access this, then that might be an issue. 



I confirm Louisa's findings. Your workflow works in my machine too:

Try first accessing the URL as Louisa suggested and also try this one:


How do your KNIME network settings look like? Mine look like this:

Are you behind a proxy? Can you try the nodes in a different internet connection, e.g. at home? 





I am sorry for this delated answer. My proxy requires authentification, but when I use a not authenticated connexion, "ChEMBL" nodes work perfectly well.

Thank you a lot for your valued assistance and for your quick reply :).



Hi Baptiste, 

Good to know - you should be able to configure proxies and credentials within KNIME in Preferences. 

Enjoy the nodes.