client TLS version being less than minimal TLS version allowed by the server (Azure Sql)

Hi Everyone,

I have reviewed a number of other threads on this issue, but those solutions did not work for me.

I have tried with the DB Connector Node:

ERROR DB Connector 3:12 Execute failed: Reason: Login failed due to client TLS version being less than minimal TLS version allowed by the server.


  • Am using the most recent Microsoft JDBC Driver for JRE 8 (12.4.1),
  • Using the JDBC string settings Microsoft provides for connecting with encryption
    ** Connecting with encryption - JDBC Driver for SQL Server | Microsoft Learn
  • Have confirmed my server requires TLS 1.2
  • Have set my Java settings on my Windows based workstation to only use only TLS 1.2 through the Java Control Panel.

Not sure what else to try.

Sincerely welcome suggestions.


Hello @NKlassen,

seems to me you are using DB Connector node and trying to connect to Microsoft SQL database. Have you tried Microsoft SQL Server Connector node?


1 Like

You can try the MS SQL Server Connector, as @ipazin suggests, or you can try and add Protocol=TLSv1.2 to the connection string (source). This might also solve the issue.
Kind regards,


Hi ipazin!

Thank you for taking the time to provide feedback. :slight_smile:

My apologies for the delayed response.

I have tried the Microsoft SQL Server Connector as well.

I got an error related to integrated authentication not being supported and am currently digging through to understand what I need to install to address it.

I believe I need to install and setup this, and then hopefully it will work.

I historically received a different error, and I felt that the TLS setting would have been easier to address.

I’ll post on the outcome of this though.

Any wisdom you may have re: MSAL would be appreciated though.



1 Like

Hi Alexander,

Thanks for your response, my apologies for the delay in responding.

I’m going to keep working through the MS SQL Server Connector challenge, it seems I may need MSAL to get it working.

I received a relatively straightfoward (seeming) TLS error with the DB Connector node, so that’s why I focused my efforts on that.

Unfortunately that connection string addition has not resolved the issue, so I’ll keep digging.

Thank you for your time :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.