[Cloudera][ImpalaJDBCDriver] Unable to connect, NetBIOS rejected by Cluster

Hi,

I have tried to connect to My Hadoop Cloudera cluster with the Impala Connector Node. I am using Kerberos authentication and the JDBC CLOUDERA Impala Driver (jdbc41, version 2.6). The connection is always getting timeout.

WARN Impala Connector 0:2 failed to apply settings: Database connection could not be validated: [Cloudera]ImpalaJDBCDriver Connection timeout expired. Details: None.
WARN KNIMEApplication$3 Potential deadlock in SWT Display thread detected. Full thread dump will follow as debug output.
ERROR Impala Connector 0:2 Exception creating Kerberos based jdbc connection. Error: null

I used Wireshark to see the connexion between the PC and the cluster. Firstly, I don’t understand why KNIME Impala Connector is sending a NetBios Name Service Message on UDP port 137? Is it possible to deactivate this message?

in the knime.log I have these ERROR Messages :
2018-09-03 17:31:10,337 : ERROR : pool-4-thread-10 : KerberosConnectionFactory : Impala Connector : 0:2 : Exception creating Kerberos based jdbc connection. Error: null
Caused by: com.cloudera.impala.support.exceptions.ErrorException: [Cloudera]ImpalaJDBCDriver Connection timeout expired. Details: None.

If anyone can help me to go further?

Regards,

Fred

Hi @fred5778

sorry, I can’t really tell you why the Impala Connector sends a NetBios name service message. Either Java does this under the hood when resolving DNS names or Cloudera’s Impala driver is secretly doing this (for which you would have to contact Cloudera about).

But honestly, I don’t think the NetBios message is really the problem here. The error message “Connection timeout” means that you cannot make a TCP/IP connection to the Impala daemon, which is something that would need to be fixed in the firewall that surrounds your cluster.

Björn

Hi Bjoern,

thanks for your answer.
I don’t think it’s a firewall pb because, I did a tcpdump on the datanode Server of my hadoop Cluster and I see the message received on the 137 Port.
To clear the NetBIOS transaction in the problem, I disabled the NetBIOS Service on my PC. Consequently, the message is not send to the cluster, and I have the same error log… Unfortunately, on WireShark, I can see that no message is sent from the PC to the Cluster.

So, I don’t know if the TCP/IP connection can’t be initiated because of a configuration error in the PC (or on KNIME) or because of the unachieved/not completed NetBIOS transaction??

Moreover, I even don’t know which service to unable on a Linux Server to enable the NetBIOS transaction on the Server (I just know that the port 137 is open)??

If you have an other idea to help me?

Fred

Hi @fred5778

the Impala Connector node connects to TCP port 21050 by default, not 137. Unless you have changed this in the configuration dialog of Impala Connector.

Hence on the server-side, you should look for incoming TCP connections on port 21050 with tcpdump. If you cannot see any, then you should check your firewall. If you can see the connection attempt with tcpdump, then you should check whether there is actually an Impala daemon listening on port 21050.

Björn