? Column data type

As shown in my work flow after 2 transpose and concatenating a data column with values to another data column without any values, I get ? for the numeric columns. I had a quick look in the topics sections on this and one of the post suggested to use column Auto-type cast but this is still not recognizing the numeric columns. Is there a way to resolve this issue?

when I concatenate a table with another that has no values the numeric columns

data_type.knwf (67.1 KB)

Hi @pio -

The Column Auto Type Cast node doesn’t currently handle unknown column types, although we do have a ticket for that (AP-11450). I can add a +1 from you on that ticket.

In the meantime, an (admittedly unintuitive) workaround is to use the Column Renamer to force conversion to strings. Then the Column Auto Type Cast will work, converting to doubles.


Hi @ScottF. Thanks that work around worked. Thanks for raising the ticket as well as this could help


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.