Column Expression Node forgets Checkbox setting

Hello all,

with the Column Expression Node I’m computing Hex-Strings to Decimals and in the following Column Expression Node I use the Two’s complement to compute negative values. Because I have to do this for 35 Columns, I try to parse the Hex-Columns in a Column List Loop. The first iteration is running fine but in the second iteration the Two’s complement Column Expression Node crashes because there are two columns insted of one becaus the first Column Expression Node “forgets” the checkbox ‘Replace Column’. This forgetfulness only happens in the second iteration…
Has anyone an idea how to fix this problem?


Just thinking out loud here - I think you need to have a flow variable to govern the output column according to the current iteration of your loop - otherwise it’s just going to try to replace the same column every time, right? Maybe that’s why the checkbox is acting strange?

Hello @ScottF,

here is a screenshot of the Column List Loop

The input column value look like this

The output of the Cell Splitter Node is a list an after the Ungroup Node my column looks like this

Because of the Column List Loop Node I have the actual column name. The Cell Splitter Node appends the name “_SplitResultList” so I append this name to the acutal column name with the String Manipilation Variable Node.

In the first iteration this configuration work fine. In the second iteration the Column Expression Node “forgets” the checkbox to replace the input column.

Thanks for the additional detail. Would it be possible to upload just this portion of the workflow with some dummy data to test it out?

I will share some data but it will take some time

Thanks for your support!

maybe some kind of workaround like using column rename regex to rename the column between the column expressions?

Hello @Brotfahrer,

control this setting with Boolean flow variable. See example here:



Hello all,

find attached the snipped of my workflow with some example data in the Table Creator Node. I hope four coulmns with data is enough. I tryed it in the example workflow and the checkbox ist missing after the first iteration.

@ipazin: I’ll have a look to your workflow


EEPROM_ColumnExpression_Loop.knwf (29.2 KB)

@ipazin that’s it. With the outputName and replaceColumn in the Flow Variables Configuration tab it works.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.