Column List Loop - Problem Submitting Multiple Files via external Table Row to Variable Loop


I have several csv files which I want to process in turn via a Column List Loop. Each has a common Key (Product ID) but different columns otherwise (number and headers).

So I am using a table with the column names and a table row loop to cycle through them, feeding a flow variable to a csv reader to input the file, and then to a Column List  Loop where the 'Product ID' column is excluded (enforced). This works fine for a single file, and for multiple presentation of the same file, but fails when the file specification changes. The error says that the 'input table does not contain the required included columns' , the expected ones being those from the previous file which did work. It seems that this loop start retains the format of the previous file and is not 'refreshed' with the new fields to be included. If I open the column loop start node and close it again and then execute it is refreshed with the new field names.

Is there a way to refresh the column list loop node automatically ?

Hello Steve,

Which version of KNIME Analytics Platform are you using?

The attached configuration worked like a charm in 3.1.1, although this folder contains multiple csv-files which differ in the number of columns. Does it roughly represent your workflow?


Hey, thanks Ferry.

I'm not sure what version I'm using actually, In the Installation details under 'About Knime' it indicates version against KNIME Analytics pltform so maybe I'm behind. I'll try to update and see if that makes any difference.

Your png is pretty much how I am trying to do it although there are some complications in between, including feeding some values into the inner loop from outside, which may be an issue.... I've attached a png of my stream for your general info and in case you spot anything obvious.

I'll let you know if an update solves the issue. Might also help with some issues I have with try and catch error trapping also....

Many thanks for your (incredibly) prompt response.




Hey Steve,

yes, you are a version behind, but unfortunately an update is not possible due to some changes to the underlying structure. You have to get a new copy from the website, but it is absolutely worth it! Besides a huge UI-makeover there are many great changes. There is a video on our youtube channel ( and of course a changelog on the website.

Meanwhile I'm going to test the loop in 2.12 and have a look at your workflow.


Okay, confirmed: This is solved by an upgrade to 3.1.1. The workflow I sent you failed in 2.12.1, so an update should solve your issue.

Hi again, I did the update and indeed that did provide solution - so all good. Didn't help with the error trapping issue I mentioned but I'll start a new post for that.

Thanks again....


I'm glad that it solved this problem.

Regarding the error trapping: There were multiple bugfixes for the try-catch-nodes in the 3.x releases. If they do not fix your difficulties, please open a post about that with more details and we are more than happy to help!