Command line execution gives exit 4 error

I am using knime to execute a workflow but am getting the following error:

I learnt that exit 4 means that there was a problem executing the workflow. However it actually executes fine since I see the output file. But it exits with this error.
The workflow also executes without any issues from the client itself.

This is the command I am using to invoke my workflow:

knime -nosplash -nosave -reset -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\knime-workspace\Extract_FG_Size”

Would appreciate any pointers on how to stop the error from popping up.
Thank you!

Hi @thentangler , are there any orphan nodes in the workflow? If so, this can be a problem. The node that generates the output might have run properly, but the workflow itself did not finish properly.

Can you show us your workflow?

1 Like

You are absolutely right sir. I do have a node that i use to initialize.
The workflow extracts some data from a database and does some aggregating and stores the result with the current timestamp in a table. I run this everyday, and append the next extraction with the new timestamp to the existing table. So basically i am creating a running table with a daily timestamp and data.
I have a node that initializes the table for the very first time and then i dont need it. However I keep it in the workspace (disconnected from anything) in case I need it in the future.

Is there any way to keep that node there but still disable it so that the auto-execute runs smoothly?
If not I can remove the node. but just wanted to find a way fi there was.
Thank You!

Hi @thentangler , you could use an IF Switch. You can create a variable that will control the execution of the node. If variable says to execute, your IF Switch executes it, else do not execute. Then link it to the rest of your workflow.


Thank you. Thats an excellent idea!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.