command line execution problem

I am experiencing a weired problem with the command line execution…

I run eclipse on a remote Linux machine using X. I have a couple of newly developed nodes and when I launch eclipse everything looks OK, I can start KNIME in normal and debug mode. I see all the nodes I created and I can execute everything and see the results.

now I execute the workflow from the command line using:
time ./eclipse -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=…/runtime-New_configuration/test\ data\ preprocessing-no\ data/

this workflow doesn’t work correctly. When I open the result I have my original workflow without my own developed nodes. I guess eclipse doesn’t know about them from the command line and I have to somehow tell it where to look… But how would I do this?



Have you exported and deployed the nodes?

Hmm, I thought I might not need to do this… :wink:
Is there a way around this?


Probably Yes. If you run the workbench from your eclipse GUI (not the batch executor), go into the “Debug” perspective and right click on the process and select “Properties”. You’ll find a field called “Command Line”. You should be able to run this command (or a slight variant enabling the batch executor) from command line.

Good luck! :slight_smile:

Here is something that worked for me. Not quite sure what all the options mean, but I highlighted the ones that I changed:

-classpath /pasteur/solexa2/solexa_travail/PF2/programs/kNime/eclipse_knime_2.1.0/plugins/org.eclipse.equinox.launcher_1.0.101.R34x_v20081125.jar
-launcher /pasteur/solexa2/solexa_travail/PF2/programs/kNime/eclipse_knime_2.1.0/eclipse
-name Eclipse
-application org.knime.product.KNIME_BATCH_APPLICATION
-workflowDir=/pasteur/solexa2/solexa_travail/PF2/programs/kNime/runtime-New_configuration/Cristel-test/ </strong>
-configuration file:/pasteur/solexa2/solexa_travail/PF2/programs/kNime/workspace2.1.0/.metadata/.plugins/org.eclipse.pde.core/MyKnime/
-dev file:/pasteur/solexa2/solexa_travail/PF2/programs/kNime/workspace2.1.0/.metadata/.plugins/org.eclipse.pde.core/MyKnime/
-debug /pasteur/solexa2/solexa_travail/PF2/programs/kNime/workspace2.1.0/.metadata/.plugins/org.eclipse.pde.core/MyKnime/.options
-os linux
-ws gtk
-arch x86_64
-nl en_US