Component with Configuration and Javascript View inside

Hi community,

i have a component with two configurations inside. In the same component is a javascript view.
With the configurations i want to configure the javascripe view. That’s all fine.
The problem:
When i run the component after setting the configurations, the javascript view did not open and the workflow throws an error.
How must i do this?
I want both, the configurations and the javascript view in the same component for sharing it.

Many thanks.

Hi @ptrwlr,

the actual error message would help to clarity your issue.
Could you provide an example Workflow?


There is no direct error message.
The Javascript View doesn’t open but executes. So the user can’t select values in the javascript view and the next node throws an error because there is no output from the javascript view.

Here is a screenshot.
Only if i select the third option for output (“table”) the javascript view doesn’t open.

Error in JSON to table

Does anyone know why in case 1 and 2 the javascript view open and in case 3 not?

Hi @ptrwlr,

what is the error message in the JSON to table node? (hovering over the red!)
Also in case (2) is the json correctly shown as variable?
Does the screenshot cover all the contents of the component?

Here is the error message.

In case 1 and 2 the javascript view opens and so the json is correctly.

Only in case 3 the javascript view doesn’t open and so there is an empty json because the user can’t do the settings to fill the json.

I don’t know why this is so.

Hi @ptrwlr,

thanks for the additional info.
But as far as I can see the problem lies somewhere in the code of the generic javascript view :frowning:
Would it be possible for you to provide an example workflow?
Else it is quite hard to determine why the view does not show…

Maybe another way around - do you need the user input? Maybe you can always give the result in all 3 formats?


thanks for your help. I will upload a example workflow tomorrow.

Here is an example workflow.

Output as flow and json is ok. Only table throws an error. (919.2 KB)


I found the solution.
I had to define the flow variable output in the javascript view as empty json {}.
Then there is now error.



Great, thanks for sharing the solution! :+1:
Just wanted to check your example but if the problem is already solved even better :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.