Components automatically inactivate on error

I am running in an unusual behavior when running some of my “old” Knime workflows that have always worked in a different way in v4.x - when I run a component that has an error in it in the current Knime AP version (v5.2.5), such component inactivates rather than showing any error + red node color.

That’s how it looks from the main workflow:

And that’s how the “processing” component looks inside:

I can get some hint on the underlying error only in the log file:

Contains one node with execution failure (Case Converter #1872)

But it would be extremely difficult to test a more complex error, and right now the only option to debug is to extract the whole component content into the outer workflow.

Is this a known bug?

Thanks for your help.

Hi @davidearonadio, welcome to the KNIME forum!

That is an odd one. I have not seen this mentioned elsewhere and haven’t experienced this myself although I make use of components quite a lot. Occasionally something crops up that affects only components, and I would guess that it is a very specific set of circumstances that is causing this, or I would expect to have seen it mentioned a few times on the forum by now. That’s not to say I read everything :wink: , so I could have simply not seen it!

Would you be able to put together a small self-contained demonstration workflow based on the above that you could upload here, as unless it is already a known issue, that would most likely help with any investigation.

btw, in the above workflow, did you determine what was wrong with the Case Converter?

Thanks for the reply @takbb :slight_smile:

I was also surprised that this never came up in the forum before :thinking:

So the specific error with the case converter was really simple (the case converter input table was missing the column it was configured to case-convert on), but I am not concerned about the specific error - it’s more about the complexity of debugging that increases a lot whenever more complex errors happen within a component.

It looked like workflows created with version 4.x would have this issue when executed with version 5.2.5, but I can’t recreate the same problem with a toy example for some reason :frowning:

We can probably this one as solved for now, and I will just post again if it ever happens again.

Thanks for the additional info.

I was wondering about the specific error to get an idea of what kind of error was occurring as that may be relevant to how the problem occurred. I was puzzled at how the case convert could be erroring, but I understand now that in the situation where it failed, it was that in effect the case converter becoming “misconfigured” because of the change in the data. That may turn out to be relevant, and useful for tracking down the scenario if something similar occurs again.

I agree that this would hamper debugging, but whilst created and used many components, any failures within the components have never caused me this problem, so I’d also be quite keen to understand it, if it happens again.

As an aside, I had a strange (different) issue with components a while back where certain components, if placed on an inactive branch would cause it to be reactivated, and thus cause the workflow to fail, but it didn’t happen for all components. It took over a year to finally find a pattern to it, (and the fix for that obscure error is coming in KNIME 5.3 :slight_smile: )

1 Like