Configuring KNIME Executor resources

Hi,

Is the “Core Tokens” value under Monitoring/Executors showing the number cores the executor is using?
If so, how can we increase it? We are using KNIME medium on AWS. Our instance has 8 cores and 64GB RAM.
Also when I change the -Xmx value in knime.ini file, it gets reset to the default value every time we reboot the server.

How can I set the default CPU cores and RAM for the KNIME executor?

:blush:

2 Likes

Hi @armingrudd,

yes. starting from 4.12, in WebPortal admin pages you see the number of core tokens currently used by executors. How many core tokens you have available in total depends on your license. Per default an executor will request as many core tokens as the number of cores available on its host. How to adjust the amount of core tokens used by an executor is described here: KNIME Server Administration Guide
Changing the amount of memory available to the executor is done as you described by adjusting -Xmx in executors knime.ini. This should not be reset by rebooting the system.

We are using “pay as you go” on AWS. So we don’t have our own license. What should we do?

But it does. How can I fix it?

:blush:

1 Like

PAYG instances will automatically make use of all the core tokens available, so there should be no need to adjust.

Regarding the reset of memory adjustments: Are you on a Windows instance? If so, there is a scheduled task that is causing this. It can be disabled via Task Scheduler, the tasked is named something like “Set memory…”. We will also disable that per default with the next version of our marketplace offerings.

1 Like

So why are we seeing 4 tokens although our instance has 8?
We have KNIME Server Medium for AWS on r5.2xlarge.
How should we make it use all the cores?

KNIME Server Medium for AWS doesn’t have any Windows options. We are using Linux and still it gets reset. How can I fix this?

1 Like