Configuring R scripting with conda

Installed R-base 3.5.1 under my Base conda environment.

Following this tutorial I tried to create a shell script pointing to the R installation, but KNIME Preferences told me there is no bin folder in the path I set to the .sh file.

Trying to put into the directly the path of R installation inside conda:

/home/myaccount/anaconda3/pkgs/r-base-3.5.1-h1e0a451_2

KNIME Preferences told me

Path to R Home does not contain a folder with name ‘library’.

where the dir contain a “lib” directory, so I’m a bit lost what I’m supposed to do.

It sounds like you are mixing R and Python installation or am I wrong?

Concerning R and KNIME I can offer this article

For Python this is the latest blog entry (Google sometimes would point you to older ones).

https://docs.knime.com/2018-12/python_installation_guide/index.html

2 Likes

Hi, I am under Debian10 and have the same issue. I want to run R in a seperate environment inside of anaconda, in order to later have many R versions next to each other.

When I tried to enter the path for R in the node configuration for R, I was told it is missing the library folder. I added one and the message vanished. But If I want to actually use the R nodes they tell me there was a problem with talking to R (Exception occured during R initialisation).
Is there a working solution how to get R in Anaconda running with KNIME? This R itself from the command line looks like to work fine. Just KNIME seems not to like it. Help is appreciated :slight_smile:
Best,
Lars

I want to mention a working solution for me! In Anaconda, I found out that the installed R was shown in a second folder. After I selected the ‘second’ R in KNIME everything worked as expected and the library folder was present. HTH Lars

1 Like