Connect Amazon S3 (old vs new node)

Hi,
I have a problem with the connection to amazon s3.

Setting up the proxy manually:

if I work with the old node (Amazon s3 connection (legacy) ), it works and I can also select directories.

If i use the two new connection nodes, the authentication part works, while the connection part doesn’t (it seems that the connection part doesn’t use the manual proxy setting, and I don’t know how to setting this, I can’t find settings in advanced).

Inside the setting is the same old and new.

This is the error:
ERROR Amazon S3 Connector x:xx Execute failed: Unable to execute HTTP request: Connect to s3.xx-xxxx-x.amazonaws.com:xxxx [s3.xx-xxxxxxxx-x.amazonaws.com/xx.xx.xxx.xx] failed: Connect timed out
WARN List Files/Folders x:xx Please specify a folder

Can you help me?
thanks !!

And

1 Like

Hi @And -

Thanks for reporting the problem. I’ve asked internally for help from someone a bit more familiar with DBs and proxy connections.

Thanks ScottF,
I’m waiting for news!!!

And

Hi,
Is there any news regarding the ticket?

thanks.

Andrea Di Carlo

Hi @And,

thanks for running tests with multiple setups. It is indeed very interesting that the legacy connection works. To be sure that this is indeed a proxy issue, is there a way for you to test the connection without a proxy?
I was not able to find any issues with the S3 Connector in combination with proxies. Still, could you confirm which version of KNIME you’re using? Should you be on an older version, could you test with a current version found here?

Another thing to try is to set up the proxy in Windows instead of KNIME and set the proxy configuration to “Native”.

Kind regards
Marvin

2 Likes

If Marvin’s solution above doesn’t get you there, it might be necessary to involve our enterprise support and/or partners. If you need help identifying a partner, let us know and someone can reach out to you for further assistance.

1 Like

Hi Marvin I’m a collegue of @And.
I’ve the same problem using the last version of Knime 4.6.5

I attach you e document with tests and logs with legacy an not.
From my home PC, without proxy everything works.

Next we try to configure the proxy al windows level

Thank for attention
Giorgio
KnimeAmazon.docx (177.6 KB)

Hi @salvatorigio,

thanks for following up and running further tests.
I’m afraid this looks to be a niche issue on a network level. It isn’t obvious to me why this would only impact the newer nodes, but this would require a more detailed investigation. Again, we are happy to put you in contact with partners of ours should you want further assistance debugging.

Kind regards
Marvin

1 Like

Hi all,
we have tryed proxy configuration T WINDOWS level and now all run correctly.
I’ve used this script as configurator:
@echo off
reg add “HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings” /v ProxyEnable /t REG_DWORD /d 1 /f
reg add “HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings” /v ProxyServer /t REG_SZ /d “proxy:port”

and set Native as preference
Have a nice day
Giorgio

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.