Connecting to Google Sheets

I’m not sure what I’m doing wrong - I’m trying to connect to Google sheets.

  1. I have authenticated using google drive and sheets read and read/write scope / permissions (i’ve tried multiple variations of this (only sheets, only drive, read only, read / write, all of them)
  2. when I click on select spreadsheet, the selection table is completely blank:

I’ve used the google connector and authentication for google analytics, not sure whey this isn’t working for me?

I also ensured that google drive and google sheets apis are enabled:

this is the workflow - and you’ll note the comment in the last node:

What am I missing? Thank you in advance for your guidance.

I @ebarr.

Have you tried the configuration from this wf?


I have the same nodes on the workflow that was in my post. When I download these workflows, I have to re-authenticate with my own credentials and when I do, the first two nodes seem to work fine, but it’s the last ‘reader’ node that isn’t reflecting a table:

The open space at the bottom is when i press “select” next to the spreadsheet named “Test” - since I’m signing in under my own credentials - I don’t have access to this?

ps - my workflow contains the same nodes - the current and deprecated google authentication (i’ve tried both) and as indicated, I have drive and sheets api ‘enabled’ - I’m wondering if there’s more that needs to be done at the google side?

Hi @ebarr .

Sorry I don’t have a solution for you. There are several responses in the forum regarding problems connecting to google sheets.

Have a look at this one.
Need Help Connecting Google Sheets Reader Node


Thank you - wondering if anyone else has had this issue? I reviewed the link you sent, and from what I can tell, I’ve done everything that is suggested - I’m using the Google Authenticator. I tried using the google drive connector and it clearly shows that there are files in there (see menu on right side, clipped for privacy)

This can be viewed when adding a table reader, set to all files. However, as we know - the table reader isn’t compatible with google sheets. But, this workflow does see the files. When I use the google sheets connector with reader - no files can be read. It’s in ‘my drive’ - not sure that is a shared environment - I’m seeing that shared environments may not work?

when selecting the google sheet:

Seems to be in a circular loop - when connecting via google sheets reader and connector, those files don’t seem to be visible.,


I thought the window was completely blank - the upper left red, yellow, green that allows you to close, minimize, or expand only had the close (red). I scrolled to the right and noticed that the window was incredible small - can’t read any of the files. This image are three screen shots stacked - you can see the select file in the middle ‘stack’:

Even though I can’t read the files, I clicked in there, then down arrow a couple times to where I thought the file was that I needed (it was in fact where I thought it was), then hit okay. The node turned from red with warning sign, to yellow - so I executed the node, and the data passed through. This seems to be a layout issue, not a data issue. This is the only node (that I’m aware of) that has this problem.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.