Connecting to HADOOP using Impala on KNIME 3.5.2

I am trying to connect to Hadoop on the Cloudera Quickstart VM. I downloaded the Impala jars and copied them to C:\Program Files\KNIME\plugins folder.

The error I get now is
Execute failed: Could not create connection to database: org.apache.thrift.protocol.TProtocol cannot be found by org.apache.hive.jdbc_1.1.0.cdh5_13_0-knimebd-20171201

Parameters
hostname: 192.168.177.128
port: 21050
database: default
parameter: AuthMech=3
username:cloudera
pass:cloudera

It does not show Impala Cloudera driver. How to install the driver on the KNIME 3.5.2 version?

Hi @ranjitbhonsale

I am afraid you may have damaged your KNIME installation by copying the Impala jars into the
C:\Program Files\KNIME\plugins folder.

Please make a fresh KNIME installation and then use the following steps to register the Impala JDBC driver:

The Cloudera JBDC come in a file called impala_jdbc_zip. Inside this ZIP file is another ZIP file: Cloudera_ImpalaJDBC41_.zip. It contains a folder with the driver files. Add this folder in KNIME under File > Preferences > KNIME > Databases (via Directory). After this, you need to restart KNIME Analytics Platform.

After the restart, if you open the Clouder Connector node it should indicate that it is using the Cloudera driver.

Best,
Björn