Continental - System ask me install extensions when they are already installed

Hi Knimers,

Something happened with my flows right now, I opened the knime and immediately the system indicates me that I have to install extensions, but the flows used to work with normally…First for “Column extentions” I don’t know why, but well, I proceeded and works, but after ask me for “Continental Nodes” all of them, so I did it again but this time doesn’t work.

Please take a look:

Thank in advance for your help.

BTW this is my V. KNIME 4.1.3

I tried all the possible escenarios, uninstall, turn off, write --clean in knime.ini…nothing works…

Have you tried to completely reinstall KNIME?

1 Like

Hi,

Not really, because I’m not setting up as an administrator on this computer, so regarding my boss’s tickets and permissions I leave this option as the last one … I read that a guy has the same problem and reinstall Knime and the problem continues so I’m not sure it works either

It should be possible to install KNIME without admin rights just by extracting the software to a local older. You could use a separate ‘installation’ in another path to test if this makes a difference. This version also could use your KNIME workspace - but the two versions would not be able to run together at the same time.

I would give it a try.

Hi @mlauber71

I tried downloading the app from knime.com, move the file to other folder and open it however it ask me to install (move to application folder) and for that it require the admin permissions. Could you please elaborate a little more on your solution? or provide the link for downloading the Knime version you mention?

Thanks in advance

You could use the ZIP archive and just extract that to a suitable folder and it should work:

https://www.knime.com/downloads/download-knime

Hi,

Is the same that I did before, I’m on Mac by the way

1 Like

Does this problem also concern other extensions than the continental one?

Hi @Mark_Ortmann,

No, just with the Continental Nodes

Thanks in advance

Hi again,

I did a ticket and the IT guy delete and re-install Knime, but the problem stay…I really don’t know what else I can do. :sob: :sob: :sob:

This sounds like a more complicated problem. These things come to my mind:

  • you could provide us with the installation details so we might get a better idea about the configuration and system *1)
  • you could delete the logfile, set it to DEBUG and try to open your workflow and try a few things so we might see what is going on and get new ideas about the problem

Could you think of any other information that might be relevant?

*1)

*2)
image

1 Like

Just moved this issue to the proper location and adapted the title. Maybe @arbe can help?

2 Likes

Thanks @Mark_Ortmann, I would love to help, but my expertise is more on the functionality of the extension than KNIME’s extension handling.
@gab1one: as my expert for embedding the Continental extension into the KNIME Analytics Platform, do you have an idea?

1 Like

Hello guys,

After the re-installation of Knime the nodes didnt work, but I desinstall all the other extentions, and just upgrade the Continental Nodes. At the moment all works fine, but Im really afraid to upgrade other nodes like “Python”

Thank you guys, for all your support

Hi @IvaR,

The Python nodes should not cause you issues with this, but the best way for experiments with extensions is a dedicated KNIME installation created from the zip file e.g. on your desktop.

best,
Gabriel

2 Likes