Correct Value displayed but Incorrect Number (Double) type in data

Hi, when I was comparing if some values in two columns were equal. I noticed that for some cases, even if it seems that the same number is displayed, it turned out one of them happened to have a different value. For instance, in the first row with the value -815.4, if I copy it in Excel, the result I have is something along the lines of the second image.

I haven’t applied string to number manipulation, the issue appears to be after I apply a GroupBy Node.


Many thanks.

Hello @sirabelk3
You can display the full precision number with the right button of your mouse by clicking in the column header. If the difference is is in a far decimal. you may have to apply a tolerance to your match column or take action for the exact match.

I hope this helps you. BR

Hi @gonhaddock appreciate your comment. The option you mentioned is Available Renderers? I did it and it says Multi-line String. How can I apply a tolerance to the match?

Hi @sirabelk3
I didn’t mentioned any option, I was just guessing the root of the misfunction of Comment/Match column, and a possible generic approach.

I don’t have enough information of your workflow, I can infer based on experience that you have generated this column with a Rule Engine comparing 3rd column == 5th column => ‘Match’ …

If you want to apply a tolerance to lets say 3rd decimal (1E-3) as displayed in your picture; you will have to calculate a ‘step’ column (delta) with the ‘Math Formula’ node like:
abs( $5th_column$ - $3rd_column$ )

Then you will have to change your ‘Rule Engine’ function focusing on your ‘step’ calculated column:

$abs_delta$ < 1E-3 => "Match"
TRUE => "No Match"

But this is just based on intuition, from your las comment I just can infer that your problem resides in the far decimal. Is it?


I got you, I might use absolute value, perhaps I can compare them as strings too. The good thing is that apparently the value now shows correctly when I export it to Excel. Many thanks for your insights. Best regards.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.