Could not initialize class net.sourceforge.tess4j.TessAPI

The flow I am using on the KNIME Server is using a Tess4J node. The ubuntu tessaract packages are installed with

apt install tesseract-ocr-all libtesseract3

but I still get the error

Tess4J 2:207:67:173
Execute failed: Could not initialize class net.sourceforge.tess4j.TessAPI

What is the problem and how can I solve it?

Hi @M42,

you shouldn’t have to install any libtesseract or so on your system All dependencies should be delivered with our plugin. Which Ubuntu are you running and which KNIME Analytics Platform version? We’ll try to reproduce the problem!



hope your good.
I found the same error: Could not initialize class net.sourceforge.

What i should to do?
I wanna extract files that have some words from PDF using TikaParser and Tess4j.


Hi @razov,

Welcome to the KNIME Forum!

What version of the KNIME Analytics Platform are you using? I’ll try to reproduce the error.


KNIME 4.6.0
I have another problem with TikaParser it not extract all the text from the PDF file what is the perfect way to do that?

Hi @razov,

Have you tried using the PDF Parser node in combination with the Document Data Extractor node? This may be a possible workaround.