Could not load license data from server. Error: KNIME Webservices are not available


#1

Hello,

I just installed knime server v4.6.2 with Knime Server Small License that expire on 2019/05/24. I can connect to the admin interface, but as soon as I want to do something, it shows me this error message “RMI executor could not be started, see log file for details”. And I try to download the log file, but I have this error message : “KNIME Webservices are not available No license for Webservice access found”. The license file is in the folder : D:\knime_server\workflow_repository\licenses. In the status page, I have these messages :

  • Error 500
  • Could not load status data from server. Error: KNIME Webservices are not available No license for Webservice access found
  • Could not load license data from server. Error: KNIME Webservices are not available No license for Webservice access found

Could you help me?


#2

Sorry to hear that. You’ll be contacted shortly with an updated license file that will enable the functionality that you need. Once you post the log files here (or DM them to me) I’ll take a look at them and help you get the executor up and running.


#3

Hi Jonfuller, thank help. The new license works fine. But I still have the error message with executor : RMI executor could not be started, see log file for details. knime-server-logs.zip (159.5 KB)
Please take a look at the attached logs zip.


#4

Can you also grab this file from the file system and share it? D:\KNIME\configuration\1528755108597.log

For reference to other forum readers. This was the line in the localhost..log file that showed me where to look:
12-Jun-2018 00:11:51.035 GRAVE [localhost-startStop-1] com.knime.enterprise.server.executor.rmi.RMIExecutorImpl.reportStartupError RMI executor could not be started. Command executed:
D:\KNIME\knime.exe --launcher.suppressErrors --launcher.ini d:\knime_server\workflow_repository\runtime\runtime_knime-rmi-50100\knime-rmi.ini
Last 4 lines of log output follow:
CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
Knime:
An error has occurred. See the log file
D:\KNIME\configuration\1528755108597.log.
Also check log file in D:\KNIME\configuration


#5

here is :
1528755108597.log (3.4 KB)


#6

Jonfuller, thank you for your help. I solved the problem with the solution you posted yesterday in response to the same question from another user. Now everything seems to work properly. I’ll try to finish the setup.


#7

Thanks for confirming. Just to confirm, which method did you use to install the executor in the first place? Downloading the executor/analytics platform from https://www.knime.com/downloads and pointing to the installation there?

If anything else crops up just ask here in the forum.

For completeness, I am posting a link to this topic which I assume is the one that has the answer.


#8

Yes, I downloaded this windows installer : KNIME 3.5.3 Installer (64bit).exe from https://www.knime.com/download-installer/2/64bit, and I customized the installation path. Apparently, it was not the right installer.


#9

Thanks for the information. I’ll make sure that we clear up the instructions for the future.