Creation of DeepLearning Environment fails in 4.5

Dear KNIMEler,
I’ve updated my KNIME version 4.4.3 (Windows 10) to 4.5 and now I encouter problems to create new DeepLearning envirinments via your build-in service at ‘File->Preferences->Knime->Python Deep Learning’. When pressing ‘New Environment’ e.g. for KERAS (having Keras and Conda selected and Conda 4.10.1 installed) the creation process returns after some minutes with a series of package compatibility problems - see attached screen shot.
Interesting to mention is that the formerly installed DL environments (see img - all on Python 3.6 and also installed via your service) are ok and working - so I have no problems to execute your DL example ‘03_Keras_Autoencoder_for_Fraud…’ works fine.
As nothing changed in my Conda environment since weeks, it seems that your creation process is struggeling.
Any hints how to solve this issue?
Erich

1 Like

Seems to be that I‘m the only one having this problem.

Hi @Erich_Gstrein,

Thanks a lot for reporting this issue. I was able to reproduce it and I filed a bug report (AP-18139 for internal reference). We will let you know once it is fixed and released.

Thanks,
Temesgen Dadi

4 Likes

Hello.
I also get the same error. If the bug is fixed, please share it with me.

Happy New Year!
I get the same error, either trying GPU or CPU. Please share bug fix with me, as well. Thank you.


@njacknis, @YooByeongYeop, @Erich_Gstrein maybe in the meantime you could take a look if this environment propagation for Keras and Tensorflow might help you:

1 Like